Launcher for AirPort Utility v5.6.1

Corey, I just downloaded it yesterday for the first time. Is there anything else you recommend?
Thank you! Chris

I just had a technician fix a caching issue with the server earlier today. Most likely, you received a corrupted version of the download, so it will not unarchive. Try downloading again from the links you received via email.

Hi, I’m getting this message when launching the airport utility launcher
sh: line 2: cd: /private/var/folders/sb/m3j7bn4n59z77hzlymvqg38c0000gn/T/AppTranslocation/F7CEF577-0AE5-40DE-A07F-01E5D0AB9574/dAirPort Utility No such file or directory

sh: line 3: ./AirPort Utility: No such file or directory

What could I do to make it running properly ?

Following the troubleshooting steps from the second post in this thread (quoted, supra) should fix the AppTranslocation issue. If it does not, please let me know.


Many Many thanks for supporting this effort!! Just made a small donation. I mistakenly purchased 6 old Airport Expresses on eBay to use for a house wide music system. With you solution they worked fine on El Capitan. Then I upgraded to Mojave and you saved my butt again. So that’s $40,000,060 worth not in the recycle bin.


1 Like

Do you have an update for macOS Catalina? Thanks!

After some initial testing, I can confirm that the Launcher is currently incompatible with macOS 10.15 “Catalina”. I have not yet found a workaround. As Apple continues to lock down macOS (typically a good thing), it becomes increasingly difficult to get little utilities like this working without becoming an “identified developer”, which is likely not an option for the Launcher, as Apple will not typically allow redistribution of their code).

I’ll try to get the Launcher working under 10.15, but I do not think success is likely.

Glad I came across your tech support page. The Catalina compatibility question is how I ended up here. I’ve used Airport stuff a very long time for all sorts of things. The 5.6.1 Launcher made my old gear useful and kept it out of the landfill. Good work on that. Hope you do find success in bringing it forward to Catalina. Thx.

Thanks for these posts. I guess that explains why in Catalina I get this message: The command terminated due to receipt of a signal. (1009). If ever there is a fix, it’ll save one more Airport Express that I would like to use to add airplay capability to my amplifier. Thanks again.

Thanks for keeping this software available and free! I used it last year to set up a Time Capsule to use for backups without an ethernet cable and it worked great.

I was having some issues connecting to the Time Capsule and decided to reset it. But now it’s not connected to WiFi, so I’m trying to use the 5.6.1 launcher again to set it up again. But this time, all my attempts to open the launcher are blocked by MacOS. I keep clicking ‘open anyway’ in the general security preferences and using control + click to open but it refuses to work. It worked once, but then I got the App Translocation error, even though I dragged the files one at a time into the Utilities folder. Now I can’t even recreate that error because my computer just refuses to run the software.

I can’t connect the TC to the router because my landlord mounted it on the ceiling and it doesn’t have any ethernet ports anyway.

Is there any other workaround here or is the TC just a brick now?

Thanks so much!

Which version of macOS are you using? If you’re using Catalina, then the Launcher will not work, and I have not found a workaround (if one even exists).

I am using Catalina, unfortunately. Thanks for your help anyway

Hi Corey,

Thanks for all the work you put on this. After googling some more I came across this article on Medium which shows how to get it to work in Catalina as well. It might not be the most proper way of doing it but it’s how I got it to work on my system.

The description is in step 5 on this ( page.

1 Like

In Catalina 10.15.4, I encountered the problem where the Airport Utility wouldn’t launch, because it was from an unknown developer. The usual trick of Control-clicking the app and then selecting “Open” wouldn’t work, because it would throw up the error that Airport Utility 5.6.1 would not run on this system.

To get around this, I removed the extended attribute from the file with this command (and then dragging in the Airport Utility 5.6.1 app to insert the path):

xattr -d

All working now, in Catalina. Thanks to all!

1 Like

Brianzo, Thankyou for the advice. Did you follow all the Steps from John Ganotis’ Medium article particularly 5. and 6. as well?

I tried only using your xattr command on the 5.6.1 App but the Launcher wouldn’t open it.

Hi Brianzo,

I have the same problem in Mojave, but could you make it easier/break it down for me how you did this part:

"To get around this, I removed the extended attribute from the file with this command (and then dragging in the Airport Utility 5.6.1 app to insert the path):

xattr -d"

Do I go into Terminal or in the Script, hope you can help! :smile:

I would imagine that could work, but I’m not particularly fond of having to disable Gatekeeper to get things running. However, that may be the only choice for those who want to keep their AirPort devices running under newer versions of macOS.

Personally, I would rather spin up a VM (with an older version of macOS) and use AirPort Utility inside the VM.

This is a proper solution. Thank you, @brianzo. I’ll add this to the Troubleshooting post, supra.


1 Like

Worked, thanks so much! Took me a while to figure out that the [ ] brackets needed to be removed/replaced as well for the path, noobie me haha! Dragging for path location worked superbly :slight_smile:

1 Like

I have been looking for a mojave update and since it came, I tried it out.

I opened the launcher through right clicking, and tried troubleshooting by re-downloading.
Can you solve this?

Screen Shot 2020-04-30 at 9.00.07