Launcher for AirPort Utility v5.6.1

I just sent you a message with alternative download links for the (already unarchived) files.

I have not been able to replicate the issue, but this is probably the easiest workaround.

Hi @mahler, I’ve got same issue than @richl.
Maybe you document are broken ?
I can easily download and extract the owls video but neither the dmg or zip for airport launcher are working.
Same error message than @richl
Could you please help me to fix that issue?
and by the way, thanks for your scripts. I was using them for a while but after a fresh reinstall, I need to recover them.

actually, I have fixed my issue by using an old Mac which is still running under OSX 10.13.
It seems that dmg or zip cannot been expand on OSX 10.14.

Thanks again @mahler for your launcher.

Thank you for this additional information. I’ll see if something has changed that means I need to re-create the archive.

I can’t get the Launcher to extract from the DMG. I am using High Sierra 10.13.6 I saw a post another user had same issues and you sent him a direct download to the 2 files. Could you possibly send it to me as well? I followed the same steps you gave the other user but it still doesn’t work. Thank you in advance! Chris

I can’t get the launcher to extract the DMG or the ZIP downloaded on my Mac. I get an error “no mountable file system”. I’m running on High Sierra MacOs 10.13.6. If you can send any fixes to this issue, that would be much appreciated. Thank you! - Jas

It would appear that there was a caching issue with one of the servers (that was resulting in corruption of the downloads), and that issue has since been resolved. If you had any trouble downloading the Launcher in the last week or so, please re-download the *.dmg or *.zip. Everything should be working again.

cc: @cteodosio @jsbillon

Corey, I just downloaded it yesterday for the first time. Is there anything else you recommend?
Thank you! Chris

I just had a technician fix a caching issue with the server earlier today. Most likely, you received a corrupted version of the download, so it will not unarchive. Try downloading again from the links you received via email.

Hi, I’m getting this message when launching the airport utility launcher
sh: line 2: cd: /private/var/folders/sb/m3j7bn4n59z77hzlymvqg38c0000gn/T/AppTranslocation/F7CEF577-0AE5-40DE-A07F-01E5D0AB9574/dAirPort Utility No such file or directory

sh: line 3: ./AirPort Utility: No such file or directory

What could I do to make it running properly ?

Following the troubleshooting steps from the second post in this thread (quoted, supra) should fix the AppTranslocation issue. If it does not, please let me know.


Many Many thanks for supporting this effort!! Just made a small donation. I mistakenly purchased 6 old Airport Expresses on eBay to use for a house wide music system. With you solution they worked fine on El Capitan. Then I upgraded to Mojave and you saved my butt again. So that’s $40,000,060 worth not in the recycle bin.


1 Like

Do you have an update for macOS Catalina? Thanks!

After some initial testing, I can confirm that the Launcher is currently incompatible with macOS 10.15 “Catalina”. I have not yet found a workaround. As Apple continues to lock down macOS (typically a good thing), it becomes increasingly difficult to get little utilities like this working without becoming an “identified developer”, which is likely not an option for the Launcher, as Apple will not typically allow redistribution of their code).

I’ll try to get the Launcher working under 10.15, but I do not think success is likely.

Glad I came across your tech support page. The Catalina compatibility question is how I ended up here. I’ve used Airport stuff a very long time for all sorts of things. The 5.6.1 Launcher made my old gear useful and kept it out of the landfill. Good work on that. Hope you do find success in bringing it forward to Catalina. Thx.

Thanks for these posts. I guess that explains why in Catalina I get this message: The command terminated due to receipt of a signal. (1009). If ever there is a fix, it’ll save one more Airport Express that I would like to use to add airplay capability to my amplifier. Thanks again.

Thanks for keeping this software available and free! I used it last year to set up a Time Capsule to use for backups without an ethernet cable and it worked great.

I was having some issues connecting to the Time Capsule and decided to reset it. But now it’s not connected to WiFi, so I’m trying to use the 5.6.1 launcher again to set it up again. But this time, all my attempts to open the launcher are blocked by MacOS. I keep clicking ‘open anyway’ in the general security preferences and using control + click to open but it refuses to work. It worked once, but then I got the App Translocation error, even though I dragged the files one at a time into the Utilities folder. Now I can’t even recreate that error because my computer just refuses to run the software.

I can’t connect the TC to the router because my landlord mounted it on the ceiling and it doesn’t have any ethernet ports anyway.

Is there any other workaround here or is the TC just a brick now?

Thanks so much!

Which version of macOS are you using? If you’re using Catalina, then the Launcher will not work, and I have not found a workaround (if one even exists).

I am using Catalina, unfortunately. Thanks for your help anyway

Hi Corey,

Thanks for all the work you put on this. After googling some more I came across this article on Medium which shows how to get it to work in Catalina as well. It might not be the most proper way of doing it but it’s how I got it to work on my system.

The description is in step 5 on this ( page.

1 Like